Back to overview
Degraded

Competition Analyzer Book Data is down

May 27, 2026 at 11:57pm UTC
Affected services
Competition Analyzer Book Data

Resolved
May 28, 2026 at 12:09am UTC

Competition Analyzer Book Data recovered.

Created
May 27, 2026 at 11:57pm UTC

Competition Analyzer Book Data is degraded.