Back to overview
Degraded

Competition Analyzer Book Data is down

May 21, 2026 at 9:29pm UTC
Affected services
Competition Analyzer Book Data

Resolved
May 21, 2026 at 10:39pm UTC

Competition Analyzer Book Data recovered.

Created
May 21, 2026 at 9:29pm UTC

Competition Analyzer Book Data is degraded.